Fix: Updated source to be compatible with python 3.7+.

ISSUES CLOSED: #1
parent e861df55
image: goblinogm/goblin-buildchain
image: goblinogm/goblin-buildchain:latest-py3.8
cache:
......@@ -9,7 +9,7 @@ test:
services:
- name: goblinogm/gremlin-server-python:latest
alias: gremlin-server
image: goblinogm/goblin-buildchain
image: goblinogm/goblin-buildchain:latest-py3.8
script:
- pip install -U codecov codacy-coverage
- pip install -U -r requirements.txt
......
......@@ -2,6 +2,7 @@
## v3.3.3
* Fixed bug preventing code from running on python 3.7+, see [issue #1](https://git.qoto.org/goblin-ogm/aiogremlin/issues/1).
## v3.3.2
* Updated allowed dependency versions, gremlinpython 3.4.4 was causing issues.
......@@ -59,7 +59,7 @@ class ResultSet:
def aggregate_to(self, val):
self._aggregate_to = val
async def __aiter__(self):
def __aiter__(self):
return self
async def __anext__(self):
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment