Commit 817f429f authored by Jeffrey Phillips Freeman's avatar Jeffrey Phillips Freeman 💥
Browse files

Removed version restrictions on bundler and rake

parent 6728df6c
......@@ -30,8 +30,8 @@ Gem::Specification.new do |spec|
spec.add_development_dependency 'abstraction', '~> 0.0.4'
spec.add_development_dependency 'json', '~> 1.8.3'
spec.add_development_dependency 'bundler', '~> 1.13'
spec.add_development_dependency 'rake', '~> 11.3.0'
spec.add_development_dependency 'bundler'
spec.add_development_dependency 'rake'
spec.add_development_dependency 'rdoc'
spec.add_development_dependency 'aruba'
spec.add_development_dependency 'serialport'
......
......@@ -2,7 +2,7 @@
require 'optparse'
require 'methadone'
require_relative '../lib/apex.rb'
require_relative '../lib/apex'
class App
include Methadone::Main
......@@ -11,6 +11,7 @@ class App
main do |needed, maybe|
puts options[:switch]
puts options[:flag]
Apex::main
end
description "APEX reference implementation for the APEX protocol."
......
require_relative 'apex/version'
require_relative 'kiss/kiss_abstract'
require_relative 'kiss/kiss_serial'
require_relative 'aprs/aprs_kiss'
module Apex
def self.main
kiss = Kiss::KissSerial.new('/dev/ttyUSB1')
aprs_kiss = Aprs::AprsKiss.new(kiss)
aprs_kiss.connect(Kiss::MODE_INIT_KENWOOD_D710)
while true
frame = aprs_kiss.read
if frame
p frame
else
sleep(1)
end
end
end
end
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment