Commit 827e590d authored by Shlee's avatar Shlee Committed by Eugen Rochko

Drop support for Ruby 2.4 from CircleCI (#12834)

* Update config.yml

* Update Gemfile

* Update README.md

* Update Gemfile

* Update Gemfile

* Update Gemfile

* Update README.md

* Update README.md
parent a31139c9
......@@ -116,13 +116,6 @@ jobs:
environment: *ruby_environment
<<: *install_ruby_dependencies
install-ruby2.4:
<<: *defaults
docker:
- image: circleci/ruby:2.4-buster-node
environment: *ruby_environment
<<: *install_ruby_dependencies
build:
<<: *defaults
steps:
......@@ -187,17 +180,6 @@ jobs:
- image: circleci/redis:5-alpine
<<: *test_steps
test-ruby2.4:
<<: *defaults
docker:
- image: circleci/ruby:2.4-buster-node
environment: *ruby_environment
- image: circleci/postgres:10.6-alpine
environment:
POSTGRES_USER: root
- image: circleci/redis:5-alpine
<<: *test_steps
test-webui:
<<: *defaults
docker:
......@@ -232,10 +214,6 @@ workflows:
requires:
- install
- install-ruby2.7
- install-ruby2.4:
requires:
- install
- install-ruby2.7
- build:
requires:
- install-ruby2.7
......@@ -254,10 +232,6 @@ workflows:
requires:
- install-ruby2.5
- build
- test-ruby2.4:
requires:
- install-ruby2.4
- build
- test-webui:
requires:
- install
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment